Welcome, Guest. Please login or register.
Did you miss your activation email?
April 24, 2024, 03:17:51 PM
Home Help Search Login Register
News: Ceriatone Forums are up and running!!!
 
Guests please register
Note: If you want to help you can donate to keep the forums alive.



Do you want to advertise on this forum ? Send me a private message.



Amplified Parts
+  Ceriatone Forum
|-+  Website, Store
| |-+  Support
| | |-+  20 watt lead and bass help
« previous next »
Pages: [1] Go Down Print
Author Topic: 20 watt lead and bass help  (Read 3992 times)
steveb
Newbie
*
Offline Offline

Posts: 13


View Profile
« on: December 31, 2008, 03:45:59 AM »

I need some of your expert advice people.

Amp started motoboating/ sputtering, replaced power tubes, no issues for approx 1 hour, has lost power, it gives me a very weak signal-sound,(volume)  not even close to what it was b4.

I have numerous matched sets of tubes, pre and power tubes. Good connections, good power good speaker cab, all verified with other guitars-cables-cabinets-etc..

Same problem

What thinks u people? Thanks for any help

Peace
Steve
Logged
M Fowler
Jr. Member
**
Offline Offline

Posts: 59


View Profile
« Reply #1 on: January 01, 2009, 06:30:37 AM »

Needs to be biased.
Logged
steveb
Newbie
*
Offline Offline

Posts: 13


View Profile
« Reply #2 on: January 01, 2009, 06:50:00 AM »

Hey thanks for the reply M

I am an expierenced player, but have not done too much techy stuff.

It was my understanding that if I used a matched set, with the same values as the original tubes from Nik, that re-biasing was not needed, since there is no bias pot on this model.

If it's not too much trouble could you please enlighten me, I don't know if I will do the work, I am just trying to get my head around this issue!

The circuit seems simple enough for me to at least narrow down the problem.

Anyway no worries Nik is on the job just wanted some opinons from expierenced builders.

Thanks
Steve
Logged
steveb
Newbie
*
Offline Offline

Posts: 13


View Profile
« Reply #3 on: January 13, 2009, 02:19:43 AM »

It was the OT, thanks to Nik, the best!
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!

CeriaTone Forum is not afiliated with Ceriatone Amplifications. The CeriaTone and name, logo and related trademarks and service marks, owned by CeriaTone. , are registered and/or used in the U.S. and many foreign countries. All other trademarks, service marks, and trade names referenced in this site are the property of their respective owners.