Welcome, Guest. Please login or register.
August 01, 2021, 07:00:56 PM
Home Help Search Login Register
News: Ceriatone Forums are up and running!!!
 
Guests please register
Note: If you want to help you can donate to keep the forums alive.










Do you want to advertise on this forum ? Send me a private message.



Amplified Parts
+  Ceriatone Forum
|-+  Website, Store
| |-+  Support
| | |-+  Centura Pedal Build - Can't Make it Work...
« previous next »
Pages: [1] Go Down Print
Author Topic: Centura Pedal Build - Can't Make it Work...  (Read 120 times)
fingolfen
Newbie
*
Offline Offline

Posts: 1


View Profile
« on: June 29, 2021, 12:11:49 PM »

I'm not an electronics expert, I know some of the very basics and have done my own LED circuits for displays, etc. - in short just enough to get myself into trouble. I picked up a Centura kit (Klon Pedal Clone) - followed the wiring diagram, but nothing. I can't get it to turn on or do anything. I've gone back through all of the solder joints to make sure I don't have any cold joints. I've double and triple checked the wiring. Everything looks correct but it's still a brick.

How do I even begin to diagnose what is wrong with this thing? I'm sadly ready to chuck the whole thing and the money I've dropped into it.  Huh?  Sad   Tongue
Logged
Pages: [1] Go Up Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!

CeriaTone Forum is not afiliated with Ceriatone Amplifications. The CeriaTone and name, logo and related trademarks and service marks, owned by CeriaTone. , are registered and/or used in the U.S. and many foreign countries. All other trademarks, service marks, and trade names referenced in this site are the property of their respective owners.